The Arsse has the following requirements:

  • A Linux server running Nginx or Apache 2.4 (tested on Ubuntu 16.04 and 18.04)
  • PHP 7.0.7 or later with the following extensions:
  • Privileges either to create and run systemd services, or to run cron jobs

Instructions for how to satisfy the PHP extension requirements for Debian systems are included in the next section.

It is also be possible to run The Arsse on other operating systems (including Windows) and with other Web servers, but the configuration required to do so is not documented in this manual.